Mozilla lanza un complemento para solucionar el problema de firma en versiones anteriores de Firefox

Mozilla lanzó ayer la corrección del complemento deshabilitado del complemento de Firefox para Firefox 47 - 56, y el arreglo del complemento deshabilitado para Firefox 61 a 65, y el arreglo del complemento deshabilitado 57 a 60 el 14 de mayo de 2019, que resuelven el problema problema de firma de complementos en versiones anteriores del navegador web Firefox cuando está instalado.

El 3 de mayo de 2019, los usuarios de Firefox comenzaron a notar que algo no andaba bien. Los complementos instalados se deshabilitaron por el navegador web y no había forma de habilitarlos de nuevo o instalar nuevas extensiones en el navegador.



Firefox utiliza un sistema de firma complementario para verificar las extensiones del navegador. El sistema usa certificados para verificar la legitimidad de los complementos, y uno de los certificados usados ​​para eso expiró ese día. El vencimiento hizo que la verificación fallara para todos los complementos.

firefox add-ons disabled

Mozilla utilizó varios métodos para controlar la situación. Usó el sistema Shield del navegador para distribuir una solución de emergencia y lanzó nuevas versiones de Firefox eso lo arregló también.



Las correcciones no ayudaron a los usuarios que ejecutaban versiones anteriores del navegador web Firefox o algunos navegadores de terceros basados ​​en el código de Firefox. Mozilla prometió que lo haría lanzar parches para versiones anteriores de Firefox también a pesar de que ya no son compatibles con la empresa.

Corrección de complementos deshabilitados para Firefox 47 - 56 es el resultado de esa promesa, o al menos parte de ella, ya que soluciona el problema de firma de complementos en Firefox 52 a 56. Corrección de complementos deshabilitados para Firefox 61 - 65 resuelve el problema en Firefox 61 a 65, y Corrección de complementos deshabilitados para Firefox 57 - 60 en Firefox 57 a 60.

Todo lo que se requiere es instalar la extensión del navegador en Firefox para solucionar el problema. La extensión instala un nuevo certificado y habilita extensiones y temas nuevamente que estaban deshabilitados.

El complemento se puede instalar en las versiones de Waterfox afectadas por el problema, así como para parchear el problema en el navegador de terceros.

El complemento lanzado es único en Mozilla AMO, ya que es la única extensión en todo el sitio que no es compatible con Firefox Quantum. Mozilla purgó todas las extensiones clásicas desde el repositorio oficial de complementos hace algunos meses.

Mozilla prometió que lanzaría correcciones para las versiones 47 a 65 de Firefox. Reveló planes para lanzar una extensión de navegador para Firefox 61 a 65 y una actualización para Firefox 47 a 60. Las extensiones solucionan el problema para todas las versiones anteriores a Quantum. Navegador web Firefox antes de Firefox 57 comenzando con Firefox 47 y todas las versiones post-cuánticas hasta la versión 65.

Ahora tu: ¿Cuál es su opinión sobre el manejo de la situación por parte de Mozilla?