Pale Moon bloquea Adblock Plus

Usuarios del Navegador web Pale Moon Quienes intenten instalar la popular extensión de bloqueo de anuncios Adblock Plus ya no podrán hacerlo, ya que el equipo de Pale Moon la agregó a la lista de bloqueo.

Los usuarios de Pale Moon que lo tienen instalado pueden haber notado que tampoco está habilitado.



Hasta ahora, Pale Moon copió la lista de bloqueo de Firefox. Contiene extensiones, complementos y otro contenido con graves problemas de seguridad o estabilidad conocidos.

Cuando intenta instalar Adblock Plus en Pale Moon, recibe el mensaje de que la extensión no se pudo instalar debido a un alto riesgo de causar problemas de estabilidad o seguridad.

pale moon adblock plus

Investigación adicional: el foro de Pale Moon suele ser un buen lugar para comenzar. revela que el equipo decidió agregar Adblock Plus a la lista de bloqueo debido a incompatibilidades con Pale Moon.



Lo puse en la lista de bloqueo porque ha comenzado a dar graves problemas de usabilidad (vea los hilos con 'barra grande con texto rojo en la parte inferior del navegador', etc.). ABP no debe usarse en ninguna versión v25 + de Pale Moon porque no es compatible.

Los problemas de compatibilidad parecen estar relacionados principalmente con la interfaz cuando Adblock Plus se ejecuta en Pale Moon.

Moonchild, el desarrollador principal de Pale Moon sugiere utilizar una alternativa como uBlock, uBlock Origin o Latitud de Adblock en lugar. Este último es una bifurcación de Adblock Plus que se desarrolla y mantiene específicamente para Pale Moon.

La respuesta de Wladimir Palant sugiere un conflicto personal entre ambos equipos y arroja algo de luz sobre la incompatibilidad técnica:

Antecedentes técnicos (al menos supongo que de eso se trata): Adblock Plus 2.6.10 dejó de usar la sintaxis de generadores de JavaScript obsoleta que solo admite Firefox. En su lugar, se está utilizando la sintaxis adecuada que cumple con los estándares: Firefox 29 y versiones posteriores lo admiten, pero Pale Moon probablemente no lo haga (bifurcaron una versión de Firefox que ya es muy antigua).

La actualización más reciente de Adblock Plus también es incompatible con las versiones de Firefox anteriores a la 29 debido a la compatibilidad de la extensión con la 'sintaxis de generadores de JavaScript conforme al estándar'. Esto significa que los usuarios anteriores a Firefox 29 no podrán usar Adblock Plus también.

Es posible que los usuarios de Pale Moon necesiten cambiar a un bloqueador de anuncios diferente. Si bien existen otras soluciones, por ejemplo, deshabilitar la lista de bloqueo, no se sugiere hacer uso de ellas, ya que pone al navegador en grave riesgo.