Kodi 19 puede romper algunos complementos

El equipo de desarrollo detrás del software de reproductor multimedia Kodi ha lanzado la primera versión nocturna de Kodi 19, con el nombre en clave Matrix, recientemente. La nueva versión de la aplicación viene con un cambio que puede romper los complementos que están disponibles para la solución.

Las versiones actuales de Kodi proporcionan complementos con acceso al intérprete de Python 2. Python 2 está a punto de llegar al final de su vida útil (el 1 de enero de 2020) y el equipo ha trabajado en la migración al intérprete de Python 3.



El problema es que la migración puede romper ciertos complementos que dependen de la funcionalidad de Python 2 o no son compatibles con Python 3 por otras razones.

kodi 19

Se anima a los desarrolladores a probar sus complementos de Kodi utilizando las compilaciones de Nightly para asegurarse de que funcionan correctamente. Si bien los desarrolladores activos pueden actualizar los complementos para que puedan ejecutarse en Kodi 19 y versiones futuras del reproductor multimedia, los complementos que ya no están en desarrollo activo no serán compatibles automáticamente.



El equipo de desarrollo quiere involucrar a la comunidad en el proceso de preparación de complementos inactivos para Kodi 19. Usuarios puede informar Se anima a los complementos que no funcionan con Kodi 19 actualmente y a los desarrolladores con habilidades en Python a que echen una mano para preparar estos complementos para la nueva versión.

Además de ese problema principal, el equipo debe abordar otros antes del lanzamiento de Kodi 19:

También hay problemas que necesitan un conocimiento básico del desarrollador para solucionarlos. Desde que se pasó a Python 3, existen algunas dificultades en todas las plataformas de Windows en particular. La versión de Kodi para UWP (Xbox) no se compila en absoluto y necesita a alguien que la defienda. También hay problemas con ciertas bibliotecas, p. Ej. Pillow, PyCryptodome, cTypes, etc., faltan versiones o son incompatibles, por lo que los complementos que dependen de ellos no se ejecutan y no se pueden probar en Windows.

Código 18.5 es la versión estable oficial que se lanzó ayer. La versión usa Python 2 para complementos y los usuarios de Kodi pueden actualizarlo sin romper ningún complemento instalado.

Los usuarios de Kodi que quieran probar Kodi 19 pueden hacerlo descargando la última compilación de Nightly utilizando la versión oficial Pagina de descarga en el sitio web de Kodi. Simplemente haga clic en descargar, seleccione el sistema operativo para el que desea descargar Kodi y cambie a la sección 'Compilaciones de desarrollo' en la superposición que se abre.

¿Cuántos complementos no serán compatibles con Kodi 19 cuando salga la nueva versión? No está claro en este momento, pero parece probable que algunos complementos no sean compatibles con la nueva versión cuando salga por primera vez.

Ahora tu: ¿usas Kodi y complementos? ¿Cuál es tu opinión sobre el desarrollo?