Pale Moon 29.2.0 ya no admite extensiones heredadas de Firefox que no están portadas

Cuando Mozilla cambió de su sistema de complementos heredado a WebExtensions, las bifurcaciones de Firefox como Pale Moon vieron un aumento en los usuarios que querían seguir usando extensiones que el nuevo sistema de Mozilla ya no admitía. No todas las extensiones funcionaron, pero muchas sí, y los usuarios pudieron seguir usando estas extensiones.

El lanzamiento de Pale Moon 29.2.0 cambia la compatibilidad de la extensión del navegador de una manera importante, ya que elimina la compatibilidad con las extensiones heredadas de Firefox que no están ajustadas para funcionar con el navegador Pale Moon. Cerca de 230 extensiones están disponibles actualmente para Pale Moon en el sitio web oficial de Pale Moon Add-ons , incluidas extensiones populares como Decentraleyes, uBlock Origin (Legacy) o FoxyProxy.

Según a una publicación en el foro de Moonchild, propietario del proyecto Pale Moon, el equipo de desarrollo siempre consideró temporal la compatibilidad con las extensiones de Firefox. Es posible que las extensiones clásicas de Firefox no se instalen en Pale Moon o que presenten problemas de compatibilidad, y esa es una de las principales razones para bloquear las extensiones clásicas de Firefox en Pale Moon 29.2.0.

compatibilidad con el complemento pale moon 29.2.0

Se pueden portar extensiones que no sean compatibles para hacerlas compatibles con el navegador Pale Moon, pero ¿quién lo va a hacer? Para el equipo del proyecto Pale Moon, la respuesta es clara. Es la comunidad la que necesita intensificar para asegurarse de que las extensiones que utilizan sigan siendo compatibles con el navegador. Siendo realistas, la mayoría de los usuarios de navegadores no saben cómo crear extensiones de navegador o modificarlas para que funcionen. El equipo de Pale Moon tampoco puede trasladar la mayoría de las extensiones del navegador al navegador, lo que deja a un pequeño grupo de miembros de la comunidad con las habilidades y el tiempo para trasladar algunas de las extensiones al navegador.

Hay un hilo disponible en el foro oficial de Pale Moon para publicar extensiones críticas solo para Firefox .

Los usuarios de Pale Moon pueden permanecer en la versión 29.1.1 del navegador como una medida temporal para seguir usando extensiones que de otra manera estarían deshabilitadas en Pale Moon 29.2.0 o posterior. Una buena opción para probar la compatibilidad es usar una copia portátil de Pale Moon 29.2.0 y probar la compatibilidad de la extensión en esa versión para ver cuáles de las extensiones instaladas siguen siendo compatibles y cuáles no. No se recomienda cambiar a una versión anterior de Pale Moon después de la instalación de la actualización 29.2.0, ya que puede presentar problemas de compatibilidad de perfil.

Pale Moon 29.2.0 se lanzó el 27 de abril de 2021 .

Ahora tu : ¿usas Pale Moon? ¿Está afectado por el cambio de compatibilidad?